DPKG Config Problem

Hallöchen!

Ich schaue gerade nicht schlecht !coffee .

Wollte eben auf meinem Server cURL nachinstallieren, da ich es für ein Projekt benötige, nun da meldet mir APT aber:

„E: Sub-process /usr/bin/dpkg returned an error code (1)“

Gut, also mal mit:

„dpgk --configure -a“

Versucht eventuell fehlende Dinge zu Konfigurieren, leider ohne Erfolg folgende Meldung:

[quote]root@antribute ~ # dpkg --configure -a
dpkg: dependency problems prevent configuration of proftpd-mod-vroot:
proftpd-mod-vroot depends on proftpd-basic (>= 1.3.4~rc2-2~); however:
Package proftpd-basic is not installed.
proftpd-mod-vroot depends on proftpd-abi-1.3.4a; however:
Package proftpd-abi-1.3.4a is not installed.

dpkg: error processing proftpd-mod-vroot (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
proftpd-mod-vroot
[/quote]

Versucht man also mal nun proftpd-basic und proftpd-abi-1.3.4a nach zu installieren (wieso auch immer die weg sind :astonished: ):

[quote]root@antribute ~ # apt-get install proftpd-basic proftpd-abi-1.3.4a
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‚proftpd-basic‘ instead of ‚proftpd-abi-1.3.4a‘
The following packages were automatically installed and are no longer required:
autotools-dev gnustep-base-common gnustep-base-runtime gnustep-common gnustep-make gobjc gobjc-4.7 libexif12 libgnustep-base1.22 libgphoto2-2 libgphoto2-port0 libgusb2 libieee1284-3 libmemcached10 libobjc4 libsane-extras libsbjson2.3
libsope-appserver4.9 libsope-core4.9 libsope-gdl1-4.9 libsope-ldap4.9 libsope-mime4.9 libsope-xml4.9 memcached openjdk-7-jre-lib sope4.9-gdl1-mysql sope4.9-libxmlsaxdriver tmpreaper
Use ‚apt-get autoremove‘ to remove them.
Suggested packages:
proftpd-doc proftpd-mod-ldap proftpd-mod-mysql proftpd-mod-odbc proftpd-mod-pgsql proftpd-mod-sqlite
The following NEW packages will be installed:
proftpd-basic
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/2,556 kB of archives.
After this operation, 4,271 kB of additional disk space will be used.
Preconfiguring packages …
(Reading database … 107552 files and directories currently installed.)
Unpacking proftpd-basic (from …/proftpd-basic_1.3.4a-5+deb7u1_amd64.deb) …
dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.4a-5+deb7u1_amd64.deb (–unpack):
trying to overwrite ‚/usr/share/locale/ko_KR/LC_MESSAGES/proftpd.mo‘, which is also in package psa-proftpd 1.3.4c-debian7.0.build115130626.18
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/proftpd-basic_1.3.4a-5+deb7u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[/quote]

Fängt mal wieder von vorne an.
Jemand eine Idee wie man das jetzt lösen könnte?
Komplett ProFTP würde ich ungern neu installieren.

MfG Syntafin

Linux ist relativ simple zu fixen wenn man sich das passende mal anzeigen lässt

das kann man ja mal so machen:

apt-get upgrade proftpd-basic ERROR code 1
danch mal
apt-get autoclean

danach nochmal

apt-get upgrade proftpd-basic ERROR code 1

danach beide logs posten.-
Sinnvoll sind immer fehlerbericht unter linux sonst wirste keine chance haben dagegen anzugehen

afaik hatte ich das Problem mit ihm per Messenger gelöst.

Resultat: Das neuere aptitude nutzen. nicht apt-get.

[quote=“Balmung”]afaik hatte ich das Problem mit ihm per Messenger gelöst.

Resultat: Das neuere aptitude nutzen. nicht apt-get.[/quote]

Stimmt, nur wundert es mich gerade das ich hier es nicht geschrieben habe :astonished: