Error: Could not connect to MySQL

Hallo,

Ich habe ein kleines Problem. Ich hatte eine Joomla Seite die perfekt funktionierte, leider habe versehen meine alte SQL Daten Bank gelöscht und meine FTP dateien auch. Ich hatte aber einen Backup meiner FTP dateien.

Nun wollte ich meine Seite wieder herstellen. Da habe ich auch einen Backup der DatenBank gefunden der ein bisschen älter ist (1 monat) (kleine änderungen wurden auf der Seite gemacht), den habe ich versucht zu importieren was mir auch gelang, und dann habe ich all meine Dateien mittels ftp, wieder an der gleichen Stelle kopiert.

Jedoch bekomme ich jetzt diese meldung wenn ich mich auf meiner Seite begebe: Database Error: Unable to connect to the Database: Could not connect to MySQL.

Was bedeudet dieser Fehler genau und wie ist er zu beheben?

Danke

Der Fehler besagt das, was da steht: Daß sich die Seite nicht mit der Datenbank verbinden kann. Wie schon im anderen Thread angesprochen, mußt du noch in der configuration.php die Datenbankdaten (DB-Name, Passwort…) anpassen.

Danke,
Ich habe die datei durchgelesen und es scheint mir alles richtig zu sein. Also die DB is richtig, der username und das passwort.

Danke im voraus.

Hallo wieder,

Da bemerke ich noch einen Problem, und ich denke dass das damit zu tun hat. Wenn ich auf meine Seite gehe: athanasius295.bplaced.net, steht der directory nicht, das heisst ich seh die Dateien nicht die ich hochgeladen habe. Erst wenn ich /Joomla_1.6.4/ hinten dran mache, dann kommt der Fehler.

(Meine Seite hatte ich nämlich nie auf dem root, aber früher als ich auf athanasius295.bplaced.net ging sah ich immer meine Ordner (davon Joomla_1.6.4).

Danke

Weil du eine index.html im root-Verzeichnis liegen hast.
Poste mal die relevanten Teile der configuration.php

Hallo hummer, Ich entschldige mich vorerst weil ich relativ neu bin und nicht sehr viel weiss. Was genau ist relevant?

Danke

Alles was mit der Datenbank zu tun hat.

public $dbtype = ‘mysql’;
public $host = ‘localhost’;
public $user = ‘athanasius295’;
public $password = ‘dr***8’;
public $db = ‘athanasius295’;
public $dbprefix = ‘jos_’;
public $live_site = ‘’;
public $secret = ‘n1LmOZAtaK8QeVin’;
public $gzip = ‘0’;
public $error_reporting = ‘-1’;
public $helpurl = ‘http://help.joomla.org/proxy/index.php?option=com_help&keyref=Help{major}{minor}:{keyref}’;
public $ftp_host = ‘athanasius295.bplaced.net’;
public $ftp_port = ‘21’;
public $ftp_user = ‘athanasius295’;
public $ftp_pass = ‘’;
public $ftp_root = ‘’;
public $ftp_enable = ‘1’;

Wenn die Datenbank so heißt (was sie sollte, wenn es die einzige ist) und das Passwort richtig ist (Groß- und Kleinschreibung beachten) sollte es passen.

Noch ein Hinweis am Rande, die FTP-Einstellungen solltest du deaktivieren, da du sonst keine Erweiterungen vom Backend aus installieren kannst, sprich $ftp_enable auf 0 setzen.

Vielen Dank. Ich habe wieder alles noch einmal nachgeschaut. Alles richtig (gross-klein), ftp enable habe ich auf 0 gesetzt. Index datei gelöscht. Aber bekomme immer den selben fehler. Liegt der Fehler vielleicht in der DB selber?

Edit: Add info:

Ich habe sogar eine Test.php datei erstellt (wie im Joomla forum beschrieben wurde, und alles war richtig)

[code]<?php
$host = ‘localhost’;
$user = ‘mysqluser’;
$pass = ‘mypass’;
$db = ‘databasename’;

//Don’t change below here
$conn = mysql_connect($host, $user, $pass);
mysql_select_db($db, $conn);
echo ‘


anything above this linebreak is BAD!’;[/code]

Ich weiss wirklich nicht mehr weiter.

Hallo an alle,

Ich habe den Fehler/Problem gefunden, meine configuration.php datei die ich verbessert hatte war die auf dem root, aber ich hatte noch eine im unterordner, und die war falsch. nachdem ich die Verbesser habe kam ich endlich weiter. (Leider mit anderen schwierigkeiten aber ich denke die sind eher wegen Joomla.

Danke an alle noch einmal ihr wart mir eine grosse Hilfe.