/ immer vor bzw. nach "

Hallo,
ich habe das Problem das in meinem Forum immer vor bzw. nach einem " ein / kommt obwohl ich es garnicht möchte. Vielleicht könnt ihr mir helfen da ich sonst nichts mit HTML bearbeiten kann da man oft " s braucht.

Danke
Zeusm

Ich vermute mal, das liegt nicht an (X)HTML, sondern an deinem
Skript für das Forum.

Kommt so eine Ausgabe nach der Verarbeitung einer
Formulareingabe zustande? Dann versucht das Skript dort
vermutlich schlauer zu sein als es wirklich ist. Das kommt relativ
häufig vor, liegt oft daran, daß der Autor versucht, seine Inhalte
vor Vandalismus zu schützen, verwendet dafür aber mangelhafte
Methoden.
Man müßte da bei dem PHP-Skript also wohl die
Formularverarbeitung optimieren, hat an sich aber nichts mit
(X)HTML zu tun, sondern mit PHP - oder bei einem Fertigskript
im günstigsten Falle mit einer anderen Voreinstellung des Skriptes.

Genauer kann man das natürlich untersuchen, wenn du eine URI
mit einem Beispiel anbietest.

Url geht nich da man es im Admin Bereich sieht,ich werd mal n Screen machen und ihn gleich in diesen Beitrag editieren. Der Fehler kommt in meinem mybb zustande falls das vielleicht dazugehört.

http://pokeboard.bplaced.de/pkboardscreen.jpg

Wie das aussieht, kann man sich vorstellen, dafür braucht man
keine Pixelgraphik.
Was man braucht, ist eine genaue Darstellung, wie sowas
zustande kommt und wie die konkrete (X)HTML-Ausgabe ist.

Wenn das wirklich das mit PHP verarbeitete Resultat einer
Formulareingabe ist, müßte man das Formular samt Verarbeitung
nutzen können und sich dann sogar das PHP-Skript selbst ansehen.

In einem anderen Forum kenne ich das Phänomen, daß auch
eine Kaskade von / oder ? erzeugt wird, insbesondere wenn man
häufig vor dem Absenden mit der Vorschau arbeitet, bevor man
absendet. Da entsteht dann mit der Zeit eine ganze Kaskade von
diesen Symbolen, was daran liegt, daß der Autor nicht sauber
zwischen der Vorschau und dem zu editierenden Text im Formular
getrennt hat und da dann einiges durcheinandergerät.

Sowas wie " kommt in PHP-Skripten häufig vor, um
Anführungszeichen gegenüber PHP zu maskieren. Wird das so
bei der Ausgabe sichtbar, liegt da ein Fehler vor, das wurde dann
also nicht wie beabsichtigt von PHP interpretiert, weil das
irrtümlich ohne Interpretation durch PHP ausgegeben wird.

Richtig ist etwa: echo “$anzahl Zwerge hat “Schneewittchen””;
Unerwünscht ist hingegen meist das Resultat von:
echo $anzahl.’ Zwerge hat “Schneewittchen”’;
oder gar von:
echo ‘$anzahl Zwerge hat “Schneewittchen”’;

Ähm… ich versteh davon zwar nur wenig aber wenn ich das richtig Verstanden habe liegts daran das irgendein Skript falsch ist und dadurch dieser Fehler zustande kommt? Ich versuch mal die Bilder mit PHP einzufügen.
EDIT: geht auch nicht,kommt das gleiche.Sorry bin Anfänger auf diesem Gebiet. Und kann es vielleicht auch am mybb liegen?

Nun, dies mybb wird das PHP-Skript sein.

Wenn ich das richtig verstanden habe, gibst du in einem
Formularfeld (textarea?) sowas ein:
Beispiel

Dann schickst du das Formular los und dies mybb macht daraus
in der Ausgabe:
<img src=‘Beispiel.png’ alt=“Beispiel”>
oder vielleicht gar:
<img src=‘Beispiel.png’ alt=“Beispiel”>

Dann ist meine Vermutung, daß eben dies mybb fehlerhaft ist,
zumindest für diesen speziellen Bereich oder diese Art von
Ausgabe - oder daß jedenfalls deine Eingabe nicht dem entspricht,
was das Skript an dieser Stelle erwartet (kein HTML erlaubt?)
Kommt ja ganz drauf an, was da vorgesehen ist, was die Ausgabe
sein soll, ob man das Resultat als sinnvoll ansieht oder als Fehler.

Wenn man sich mit PHP auskennt, kann man das eventuell
selber korrigieren. Kann aber viel hilfreicher sein, daß mit den
Autoren dieses mybb zu diskutieren - oder zumindest in einem
speziellen Forum zu diesem Skript. Vielleicht gibt es da ja
irgendwo eine Einstellung, wo man das ändern kann oder der
Fehler ist bereits bekannt und in einer neueren Version behoben
oder dies ist bereits in Arbeit oder man kann die Autoren dazu
veranlassen, den Fehler in einer neuen Version zu beheben.

Thx für deine Hilfe,werd gleich mal im Forum vom mybb Fragen. Mybb ist eine Forensoftware,kein Skript ;D

mybb ist das hier?:
de.wikipedia.org/wiki/MyBulletinBoard

Dann ist es ein PHP-Skript ;o)

Du meinst einen , und keinen /.

Und dieses Problem ist uralt, es liegt an einer PHP-Einstelung namens magic_quotes_gpc. Mit diesem Stichwort findest du sicher genügend Quellen die dir sagen, was du dagegen machen kannst.

Erstelle eine Datei mit dem Namen “.php.ini” im root-Verzeichnis (/) deines Webspaces mit dem Inhalt:

magic_quotes_gpc = Off