Internal Server Error

Immer wenn ich eine Datei in einen Ordner uploade kommt folgendes:

[code]Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.2 Server at Port 80[/code]

Kann mir da jemand helfen?


poste mal dein .htaccess


[code]# Elgg htaccess directives

Copyright Curverider Ltd 2008-2009

License GNU Public License version 2


<IfModule !mod_rewrite.c>
# ugly ugly hack to detect missing mod_rewrite
# RedirectMatch must be to an absolute destination, so forces 500 error…
ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup."
RedirectMatch 302 .* index.php

<Files “htaccess_dist”>
order allow,deny
deny from all

Don’t listing directory

Options -Indexes

Follow symbolic links

Options +FollowSymLinks

Default handler

DirectoryIndex index.php

Turn on expiry

ExpiresActive On ExpiresDefault "access plus 10 years"

php 4, apache 1.x

ErrorDocument 500 "Elgg error: Elgg does not support PHP 4." RedirectMatch 302 .* index.php

php 4, apache 2

ErrorDocument 500 "Elgg error: Elgg does not support PHP 4." RedirectMatch 302 .* index.php

php 5, apache 1 and 2

# default memory limit to 64Mb php_value memory_limit 64M # to make sure register global is off php_value register_globals 0 # max post size to 8Mb php_value post_max_size 8388608 # upload size limit to 5Mb php_value upload_max_filesize 5242880 # hide errors, enable only if debug enabled php_value display_errors 0

Turn on mod_gzip if available

mod_gzip_on yes mod_gzip_dechunk yes mod_gzip_keep_workfiles No mod_gzip_minimum_file_size 1000 mod_gzip_maximum_file_size 1000000 mod_gzip_maximum_inmem_size 1000000 mod_gzip_item_include mime ^text/.* mod_gzip_item_include mime ^application/javascript$ mod_gzip_item_include mime ^application/x-javascript$ # Exclude old browsers and images since IE has trouble with this mod_gzip_item_exclude reqheader "User-Agent: .*Mozilla/4\..*\[" mod_gzip_item_exclude mime ^image/.*

Apache2 deflate support if available

Important note: mod_headers is required for correct functioning across proxies.

AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript application/x-javascript BrowserMatch ^Mozilla/4 gzip-only-text/html BrowserMatch ^Mozilla/4\.[0678] no-gzip BrowserMatch \bMSIE !no-gzip Header append Vary User-Agent env=!dont-vary
# The following is to disable compression for actions. The reason being is that these
# may offer direct downloads which (since the initial request comes in as text/html and headers
# get changed in the script) get double compressed and become unusable when downloaded by IE.
SetEnvIfNoCase Request_URI action\/* no-gzip dont-vary
SetEnvIfNoCase Request_URI actions\/* no-gzip dont-vary

Configure ETags

<FilesMatch “.(jpg|jpeg|gif|png|mp3|flv|mov|avi|3pg|html|htm|swf)$”>
FileETag MTime Size

RewriteEngine on

If Elgg is in a subdirectory on your site, you might need to add a RewriteBase line

containing the path from your site root to elgg’s root. e.g. If your site is and Elgg is in, you might need

#RewriteBase /sites/elgg/

here, only without the # in front.

If you’re not running Elgg in a subdirectory on your site, but still getting lots

of 404 errors beyond the front page, you could instead try:

#RewriteBase /

RewriteRule ^action/([A-Za-z0-9_-/]+)$ engine/handlers/action_handler.php?action=$1

RewriteRule ^services/api/([A-Za-z0-9_-]+)/(.*)$ engine/handlers/service_handler.php?handler=$1&request=$2

RewriteRule ^export/([A-Za-z]+)/([0-9]+)$ services/export/handler.php?view=$1&guid=$2
RewriteRule ^export/([A-Za-z]+)/([0-9]+)/$ services/export/handler.php?view=$1&guid=$2
RewriteRule ^export/([A-Za-z]+)/([0-9]+)/([A-Za-z]+)/([A-Za-z0-9_]+)/$ services/export/handler.php?view=$1&guid=$2&type=$3&idname=$4

RewriteRule ^_css/css.css$ _css/css.php

RewriteRule ^pg/([A-Za-z0-9_-]+)/(.*)$ engine/handlers/pagehandler.php?handler=$1&page=$2
RewriteRule ^pg/([A-Za-z0-9_-]+)$ engine/handlers/pagehandler.php?handler=$1

RewriteRule xml-rpc.php engine/handlers/xml-rpc_handler.php
RewriteRule mt/mt-xmlrpc.cgi engine/handlers/xml-rpc_handler.php

RewriteRule ^tag/(.+)/?$ engine/handlers/pagehandler.php?handler=search&page=$1


Setze mal vor dem Options +FollowSymLinks ein #
Das kannst Du auch vor <IfModule !mod_rewrite.c> und ErrorDocument 500 "Elgg error: Apache does not have mod_rewrite loaded. Please check your Apache setup. und RedirectMatch 302 .* index.php und </IfModule> setzen.

hat funktioniert!


/topic closed