Joomla 1.5.23 Installation Error

Hallo!
Ich habe ein Problem mit, dass die Joomla ist und wenn man etwas installieren will bekomme ich diese Fehlermeldung.

[code] JInstaller::install: SQL hiba. DB function failed with error number 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘TYPE=MyISAM’ at line 20 SQL=CREATE TABLE IF NOT EXISTS jos_easybook ( id int(10) NOT NULL auto_increment, gbip varchar(15) NOT NULL default ‘’, gbname varchar(40) NOT NULL default ‘’, gbmail varchar(60) default NULL, gbmailshow tinyint(1) NOT NULL default ‘0’, gbloca varchar(50) default NULL, gbpage varchar(150) default NULL, gbvote int(10) default NULL, gbtext text NOT NULL, gbdate datetime default NULL, gbcomment text, published tinyint(1) NOT NULL default ‘0’, gbicq varchar(20) default NULL, gbaim varchar(50) default NULL, gbmsn varchar(50) default NULL, gbyah varchar(50) default NULL, gbskype varchar(50) default NULL, PRIMARY KEY (id) ) TYPE=MyISAM;
SQL =

    CREATE TABLE IF NOT EXISTS  `jos_easybook` (
              `id` int(10) NOT NULL auto_increment,
              `gbip` varchar(15) NOT NULL default '',
              `gbname` varchar(40) NOT NULL default '',
              `gbmail` varchar(60) default NULL,
              `gbmailshow` tinyint(1) NOT NULL default '0',
              `gbloca` varchar(50) default NULL,
              `gbpage` varchar(150) default NULL,
              `gbvote` int(10) default NULL,
              `gbtext` text NOT NULL,
              `gbdate` datetime default NULL,
              `gbcomment` text,
              `published` tinyint(1) NOT NULL default '0',
              `gbicq` varchar(20) default NULL,
              `gbaim` varchar(50) default NULL,
              `gbmsn` varchar(50) default NULL,
              `gbyah` varchar(50) default NULL,
              `gbskype` varchar(50) default NULL,
              PRIMARY KEY  (`id`)
            ) TYPE=MyISAM;

    Komponens Telepítés: SQL hiba, ill. hiányzik vagy nem olvasható az SQL fájl. DB function failed with error number 1064
    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 20 SQL=CREATE TABLE IF NOT EXISTS `jos_easybook` ( `id` int(10) NOT NULL auto_increment, `gbip` varchar(15) NOT NULL default '', `gbname` varchar(40) NOT NULL default '', `gbmail` varchar(60) default NULL, `gbmailshow` tinyint(1) NOT NULL default '0', `gbloca` varchar(50) default NULL, `gbpage` varchar(150) default NULL, `gbvote` int(10) default NULL, `gbtext` text NOT NULL, `gbdate` datetime default NULL, `gbcomment` text, `published` tinyint(1) NOT NULL default '0', `gbicq` varchar(20) default NULL, `gbaim` varchar(50) default NULL, `gbmsn` varchar(50) default NULL, `gbyah` varchar(50) default NULL, `gbskype` varchar(50) default NULL, PRIMARY KEY (`id`) ) TYPE=MyISAM;
    SQL =

    CREATE TABLE IF NOT EXISTS  `jos_easybook` (
              `id` int(10) NOT NULL auto_increment,
              `gbip` varchar(15) NOT NULL default '',
              `gbname` varchar(40) NOT NULL default '',
              `gbmail` varchar(60) default NULL,
              `gbmailshow` tinyint(1) NOT NULL default '0',
              `gbloca` varchar(50) default NULL,
              `gbpage` varchar(150) default NULL,
              `gbvote` int(10) default NULL,
              `gbtext` text NOT NULL,
              `gbdate` datetime default NULL,
              `gbcomment` text,
              `published` tinyint(1) NOT NULL default '0',
              `gbicq` varchar(20) default NULL,
              `gbaim` varchar(50) default NULL,
              `gbmsn` varchar(50) default NULL,
              `gbyah` varchar(50) default NULL,
              `gbskype` varchar(50) default NULL,
              PRIMARY KEY  (`id`)
            ) TYPE=MyISAM;

[/code]

Der Teil TYPE=MyISAM ist seit vielen Jahren veraltet und wird von der aktuellen MySQL-Version (die auf bplaced läuft) nicht mehr unterstützt.

Du kannst jetzt entweder selbst das TYPE durch ENGINE ersetzen oder dich an die Joomla-Entwickler wenden.

Ja. Ich habe gelesen, dass die TYPE = MyISAM für ENGINE = MyISAM gemacht werden kann.

Hallo,

mit der neuseten 1.6er Version sollte es meines Wissens problemlos gehen.

Ja. Ich habe versucht. Dann ist etwas falsch. Deshalb denke ich, dass es der Hase im Pfeffer. Ich habe gelesen, dass andere diese Art der Störung war. Er schrieb einen Hosting-Service und Reparatur. Ich denke, es gibt keine solche Möglichkeit. Wie führe ich ein Upgrade können Sie Platz?
Ideen?

Wenn ich das richtig sehe, versuchst du das Easybook zu installieren. Das wird schon seit Ewigkeiten nicht mehr weiter entwickelt, weshalb da wohl noch TYPE=MyISAM drin steht. Versuchs mal mit Easybook Reloaded oder einem anderen Gästebuch.

Ja. Vielleicht. Jetzt versuche ich zu Joomla 1.6 zu aktualisieren, aber werde nicht zulassen. Ich habe versucht, die phocaguestbook, ein Gästebuch, aber nicht gelang. Doch die Installation, sondern bekommen es im Inneren.

Dieser Fehler sollte eigentlich in der Version 1.5.23 behoben sein, eine Installation der Versionen bis 1.5.22 sollte daran scheitern!

Du kannst nicht von Joomla 1.5 auf 1.6 upgraden. Es gibt nur eine Migration.
Wenn du eine Komponente installieren willst, muß die natürlich für die entsprechende Joomla-Version sein.

Der Fehler, den du jetzt bekommst, könnte damit zusammen hängen, dass du den Legacy-Modus benutzt. Deaktiviere den mal unter Plugins.

Ich habe das Upgrade. EasyBook Ich habe versucht, die Komponente aber die gleichen Fehler zu installieren. Es gab keine Ahnung. Solche Fehler in der Vergangenheit nie geschrieben. Kann das Problem NALLET ist nicht mit Ihnen, aber Ihr Hosting-Server?
Wenn es schwierig ist zu verstehen, was ich in zu schreiben, weil ich ein ungarisches bin.

Do you speak English?

The problem is that in the new version of MySQL - which is running here - „TYPE=MyISAM“ isn’t correct anymore. Now it has to be „ENGINE=MyISAM“. However, this is marked as deprecated since about 6 years. Still, many developers use it.

Those commands are mostly used for the installers only. For mods and stuff like that you can try to replace it by yourself - you will most likely find those commands in the install files.

But better use the new version of Joomla here.

Greetz :wink2:

Ich denke es wäre einfacher, wenn du das ganze nicht übersetzt sondern lieber in englisch schreiben würdest, das könnte dem Verständnis enorm helfen.

I think that it would be better, if you’d write in englisch, because that could help us to understand better. :slight_smile:

Leider kann ich nicht mehr klar zu beschreiben, weil sie nicht die gleiche in beiden Sprachen die Konjugation sind. Aber der Punkt ist, dass es nicht funktioniert, weder 5,1 noch 1,6-al.


Sorry I can not describe more clearly because they are not the same in the two languages ​​the conjugation. But the point is that neither 1.5 nor 1.6 will not work.

Welche Joomla-Version hast du genau und welche Version hat das Phoca-Guestbook. Hast du schon versucht, unter 1.5 den Legacy-Mode zu deaktivieren (findest du unter Plugins)?

edit: Ich habe bei der Installtion von Phoca-Guestbook (1.4.4) unter Joomla 1.5.23 keine Probleme.

Ich gebe auf. Ich weiß nicht, warum ich nicht gehen. Ich habe auch Phoca 1.4.4 ist auch in dem Bild zu sehen, aber kann es nicht weitergehen. Das soll installiert werden, aber nicht die Datenbank zu erstellen. Warum es nicht. Deshalb denke ich, dass es ein Problem mit dem Server. Denn jetzt habe ich diese Probleme seit dem phpmíadmin aktualisiert. Was kann ich tun?

hallo,

nichts, ausser den Entwickler der Software/Komponente Informieren, dass er doch seine Software aktualisieren soll. Mit der neuen MySQL Version wurden diverse Syntaxen welche seit 5 Jahren (!) als veraltet gelten abgeschafft. Die Entwickler sind hier dem ganzen einfach nicht nach gekommen und so lässt sich das ganze auch nicht mehr Installieren. Das hat weder mit dem Server, noch mit der neuen phpmyadmin Version oder bplaced zu tun - sondern nur damit, dass die Entwickler die Software nicht aktuell halten.

gruss

Ja. Ich verstehe. Also, wenn ich die aktuelle Version verstehen nicht unterstützt Joomla. Es gibt jetzt eine Joomla 1.7. Haben Sie diese Erfahrung? Dies wird unterstützt?