Piwik Installation - Problem

ich bin’s mal wieder. Wurde in letzter Zeit wieder mal irgendetwas an den PHP5 Einstellungen geschraubt?

Bisher setzte ich Piwik als Webanalysetool ein. Bisher haben die Updates auch alle geklappt. Nur bei der neuen Version (Piwik 0.4.3) vom 11. August haperts jetzt gewaltig und ich bekomme eine Fehlermeldung nach dem Update der Datenbank:

Warning: fwrite() expects parameter 1 to be resource, null given in /users/aschnabel/www/piwik/core/Piwik.php on line 999 Backtrace -->#0 Piwik_ErrorHandler(2, fwrite() expects parameter 1 to be resource, null given, /users/aschnabel/www/piwik/core/Piwik.php, 999, Array ([aUrl] => http://api.piwik.org/1.0/getLatestVersion/?piwik_version=0.4.3&php_version=5.3.0&url=http%3A%2F%2Faschnabel.bplaced.net%2Fpiwik%2F&trigger=,[timeout] => 2,[userAgent] => ,[destinationPath] => ,[followDepth] => 0,[file] => ,[url] => Array ([scheme] => http,[host] => api.piwik.org,[path] => /1.0/getLatestVersion/,[query] => piwik_version=0.4.3&php_version=5.3.0&url=http%3A%2F%2Faschnabel.bplaced.net%2Fpiwik%2F&trigger=),[host] => api.piwik.org,[port] => 80,[path] => /1.0/getLatestVersion/?piwik_version=0.4.3&php_version=5.3.0&url=http%3A%2F%2Faschnabel.bplaced.net%2Fpiwik%2F&trigger=,[errno] => ,[errstr] => ,[fsock] => )) #1 fwrite(, GET /1.0/getLatestVersion/?piwik_version=0.4.3&php_version=5.3.0&url=http%3A%2F%2Faschnabel.bplaced.net%2Fpiwik%2F&trigger= HTTP/1.0 Host: api.piwik.org User-Agent: Piwik/0.4.3 Referer: http://91.38.184.208/ Connection: close ) called at [/users/aschnabel/www/piwik/core/Piwik.php:999] #2 Piwik::sendHttpRequest(http://api.piwik.org/1.0/getLatestVersion/?piwik_version=0.4.3&php_version=5.3.0&url=http%3A%2F%2Faschnabel.bplaced.net%2Fpiwik%2F&trigger=, 2) called at [/users/aschnabel/www/piwik/core/UpdateCheck.php:35] #3 Piwik_UpdateCheck::check() called at [/users/aschnabel/www/piwik/core/FrontController.php:237] #4 Piwik_FrontController->init() called at [/users/aschnabel/www/piwik/index.php:64] 

Nicht dass die Piwik Leute nun fsockopen voraussetzen? :motz:

Noch niemand eine Idee? :morgen:

Habe zumindest eine Zwischenlösung im Piwik-Forum gefunden: forum.piwik.org/index.php?showtopic=1372

Die Software fragt Updates vom Piwik-Server ab, so dass fsockopen vorausgesetzt wird. :susp:
Ich habe einfach in der /core/FrontController.php die Zeile 237

Piwik_UpdateCheck::check(); auskommentieren

/* Piwik_UpdateCheck::check(); */

Jetzt funzt es zumindestens bis zum nächsten Update. :wink:

P.S. Hoffentlich wird tatsächlich mal fsockopen 2010 freigeschaltet. :wink:

Könnten wir das Thema nochmal aufgreifen, wollte jetzt keinen neuen Thread starten.

Also ich komme “durch die auskommentierte Zeile” zumindest wieder auf das Dashboard. Allerdings bekomme ich jetzt keine Grafiken mehr angezeigt. Alles funktioniert, bis auf Grafiken.

Cache mehrmals gelöscht, mehrmals Piwik komplett neuinstalliert nichts.
Ich habe es schon aufgegeben, wenn jemand noch eine Idee hätte.

MFG
Daniel

Ich schließe mich dem Problem an und hoffe auf eine Lösung.

Versuche mal das Flash-Plugin für den Browser neu zu installieren. Man kann natürlich auch die MySQL-Datenbank von Piwik löschen (vorher Backup mit MySQLDumper machen, falls man die Daten noch braucht) und Piwik (neuste Version) von Grund auf neu installieren. Bei mir hat jedenfalls das Auskommentieren der Zeile in der FrontController.php geholfen, so dass Piwik nun ohne Probleme funktioniert.

Das es mit dem FlashPlugin nichts zu tun haben kann, sehe ich jetzt als bewiesen.
Habe sogar von meinem Arbeitsplatz keine korrekte Darstellung erhalten können.
Ich habe es jetzt schon mit 6 Computern versucht, nichts…

Es scheint so, als wäre Piwik einfach nicht mehr in der Lage, Grafiken zu produzieren.

Das mit der Datenbank werde ich versuchen. Werde mich dann nochmal melden.

MFG
Daniel