Two problems regarding CDN and ETags

Recently I have come across a very useful article Best Practices for Speeding Up Your Web Site.

And the two most useful two practices I think is CDN and ETags. Which I have some trouble with, and I’m wondering that can staff help us on these issues.

For CDN, there is a free CDN out there called CoralCDN, it is a free P2P CDN network. It is used by simply adding behind the domain name. For example: The problem is: While I am using this service on my domain, it always directs me to a blank single-ad page provided by, note that this page also shows when I first set my domain A record to the server, it shows the same page for about 3 hours. But while I use some proxies, it seems to be fine. I don’t know why, so hope the staffs can give a solution to this. I will also try other CDNs and keep this thread updated to see if the same problem persists.

For ETags, it is apparently not very good to keep them open, and it is wise to eliminate all ETags. Can provide a function to automatically enable and disable the ETags? The method is stated below:
Removing the ETag reduces the size of the HTTP headers in both the response and subsequent requests. This Microsoft Support article describes how to remove ETags. In Apache, this is done by simply adding the following line to your Apache configuration file:
FileETag none

After modifying the DNS-records, it needs some time until the changes take effect. You have to wait between a few minutes and up tp 48 hours. This depends on the update-interval of your DNS. After the DNS ist set up and works correctly, your CDN should work, too.

I don’t see bplaced generating ETags, so why do you bother about them?

Just an update:

The CDN problem I think it is due to the CDN network, so it is fine.

As to the ETags, I tried to loading time testing website, and it tells me that I have too many ETags in my wordpress page. I haven’t throughly tested it yet, but I will certainly test this on other websites. I also learned that the ETags might be configured in the .htaccess file, so I will try that, and see how it goes.

It is all about learning, isn’t it? :smiley:

OK, it works fine, I think you guys should try it.

just add FileETag none in the .htaccess file in the directory you want.