Video + HTML5 einbinden + Domain


#1

Hallo liebe Forumer,

habe folgendes Problem,
mein mit html5 eingebundes Video läuft unter:
xxxxxxxx.bplaced.net/waldfrieden/arbeit01.html

nicht aber unter meiner Domain:
xxxxxxx.de/arbeit01.html

hier kommt die Fehlermeldung : Kein Video mit unterstütztem Format und MIME-Type gefunden.

Wie kommt soetwas zustande und wie behebe ich das?

Hier mein HTML:

<section>
	<video width="864" height="482" controls poster="bilder/arbeit01/01-02.png">
		<source src="bilder/arbeit01/01-02.mp4" type="video/mp4" />
		<source src="bilder/arbeit01/01-02.ogg" type="video/ogg" />
		<source src="bilder/arbeit01/01-02.webm" type="video/webm" />
			Ihr Browser kann dieses Video nicht wiedergeben.<br> 
		        Sie können es unter <a href="http://xxxxxxxx.bplaced.net/bilder/arbeit01/01-02.mp4">Video-Link</a> downloaden.
	</video>
</section>

#2

Der Link zu deine bplaced-Seite ist ja misanthrop.bplaced.de/waldfrieden/arbeit01.html
So weit so gut. Deine Domain lautet wie?
Irgendwie sollte ja schon klar sein, dass es ohne konkrete Daten schon recht schwierig ist auch konkrete Hilfe zu geben.


#3

Okay, tut mir leid. Mein Fehler.

Also wie schon richtig gesschrieben wurde, das Video läuft ordnungsgemäss
unter: http://misanthrop.bplaced.net/waldfrieden/arbeit01.html,
das Video lässt sich starten.

Nicht aber wenn ich dieselbe Seite mit meiner Domain: http://www.tassilosturm.de/arbeit01.html aufrufe!
Dann erscheint nach einiger Zeit die Fehlermeldung: Kein video mit unterstütztem Format
und Mime-typ gefunden.

Wie kommt das? Muss ich die Videos “absolut” adressieren?

Grüsse der einsiedelnde!


#4

Hi einsiedlerX,

die Medien müsstest du mit einem absoluten Pfad angeben.

Verlinkungen (real):
http://misanthrop.bplaced.net/waldfrieden/arbeit01.html
verlinkt auf das Medium
http://misanthrop.bplaced.net/waldfrieden/bilder/arbeit01/01-02.mp4

http://www.tassilosturm.de/arbeit01.html
verlinkt auf das Medium
http://www.tassilosturm.de/bilder/arbeit01/01-02.mp4

das 2. Medium existiert nicht da hier der Ordner “waldfrieden” nicht angesteuert wird.
die “tassilosturm.de” Domain verlinkt auf einen Unterordner, welcher in der URL nicht mehr angegeben wird. Die Links zu den Medien beziehen sich im relativen Pfad aber auf die aktuelle URL. Deshalb wirst du bei dieser Konstelation nicht um einen absoluten Pfad herrum kommen.

Also aus

müsste

werden.
Dann sollten alle Medien ohne Probleme dargestellt werden.


#5

Würde der von dir beschriebene Fall vorliegen icatch, würden auch die Bilder nicht anzeigt werden. Werden sie aber. Du kannst also davon ausgehen, dass die Domain auf den Ordner waldfrieden zeigt. Der darin liegende Ordner Bilder mit Unterordnern ist problemlos aufrufbar und auch am relativen Pfad liegt es nicht, da die Videos auch aus dem Ordner heraus nicht gestartet werden können.


#6

Hi Mohyra,

wenn man die Bilder aufruft, und die URL trackt, stellt man fest, das die URL weiter geleitet wird. Ich schätze dies geschieht über eine .htaccess Datei (kann auch über eine php Datei geschehen, glaube ich aber nicht), welche unter “http://misanthrop.bplaced.net/(.htaccess)” oder “http://misanthrop.bplaced.net/bilder/(.htaccess)” zu finden ist.

Der Bildlink von:

leitet auf:

weiter, via header.
Ohne eine header Angabe von “404,303” oder der gleichen.
Alle Elemente, welche auf einen Schlag geladen werden und nicht über den Server “gestreamt” werden, werden trotz der Weiterleitung angezeigt, da diese mit einem mal vom Server geladen werden können.

Da das Video aber gestreamt wird, kann dies nicht über die Weiterleitung angezeigt werden, da hier jeder Datensatz via Weiterleitung geladen werden müsste.

Somit könnte man theoretisch die Bilder so wie gehabt anzeigen lassen (mit der Weiterleitung). Das Video MUSS aber in diesem Fall einen absoluten Pfad besitzen; bzw. man erstellt eine php Datei, welche die jeweilige Datei mit dem richtigen header ausgibt.

PS: So etwas habe ich zum ersten mal gesehen (aktiv). Man lernt selbst nie aus. Dachte nach deinem Beitrag, das meine erste Antwort falsch gewesen wäre, da dein Beitrag eigentlich Sinn ergeben hat, und dies so wie dus geschrieben hast eigentlich richtig ist (normaler weise).


#7

Ähm…, wenn ich mich mal einmischen darf,

weil ich dachte es würde mein beheben habe ich lediglich eine .htaccess erstellt
mit folgendem Inhalt:

AddType video/ogg .ogv
AddType video/ogg .ogg
AddType video/webm .webm
AddType video/mp4 .mp4

Ansonsten habe ich keine .htaccess

Soll / kann ich die wieder löschen???

Nun, was mache ich nun, ich verstehe echt nur Bahnhof!

Momentan habe ich folgendes dort stehen:

<section>
	<video width="864" height="482" controls poster="bilder/arbeit01/01-02.png">
		<source src="http://misanthrop.bplaced.net/waldfrieden/bilder/arbeit01/01-02.mp4" type="video/mp4" />
		<source src="http://misanthrop.bplaced.net/waldfrieden/bilder/arbeit01/01-02.ogg" type="video/ogg" />
		<source src="http://misanthrop.bplaced.net/waldfrieden/bilder/arbeit01/01-02.webm" type="video/webm" />
			Ihr Browser kann dieses Video nicht wiedergeben.<br> 
			Sie können es unter <a href="http://misanthrop.bplaced.net/waldfrieden/bilder/arbeit01/01-02.mp4">Video-Link</a> downloaden.
					</video>
</section>

Meinen Sie dies so???

Gruss der einsiedelnde


#8

Hi einsiedlerX,

das Video wird mit dem neu hinterlegtem (absoluten) Pfad, auf beiden Domains, normal angezeigt.

Jetzt passt alles.

Die .htaccess Datei kann eigentlich gelöscht werden. Ich würde diese aber drinnen lassen, da Sie nicht schadet und vielleicht durch ein Script oder für die Umleitung gebraucht wird.