Webspace Index "verstecken"

hey Leute!
hab folgendes kleines Problem:
Wenn man meinen bplaced namen weiß, kann man ja mit “http://MeinName.bplaced.net” meinen gesamten Webspace Inhalt sehen. Alle Projekte mit ihren Ordnern und Unterordnern sind sicht- und direkt aufrufbar.
Kann man die nicht iwie verstecken oder mit einem Passwort schützen?
would be niCe :slight_smile:

Jap, kann man, such mal im Forum nach htaccess ^^ Google hilft ebenso

du kannst aber auch einfach eine index.html in das Hauptverzeichnis legen, dann wird diese und nicht die Verzeichnisstruktur angezeigt.

danke für die schnellen antworten.
@simi: ja problem ist nur, dass ich selber schon noch gerne die index Funktion nutzen würde (ist so schön übersichtlich^^)
@michi: danke, das stichwort hat mir gefehlt :wink:

Kannst auch per index.php die du in den Root legst, auf denjenigen Ordner weiterleiten, den du als Standard haben möchtest. Index.html im Root kann weiterhin genutzt werden.

ich würds mit der index.html/.php mit weiterleitung machen:

[code]

[/code] (content="1; --> 1 steht für 1 sekunde)

oder einfach eine leere index.html/.php in das verzeichnis

willst du eigentlich nur einen ordner “schützen” oder deinen gesamten space??

jo ich hatte vor, den gesamten space mit einem passwort zu schützen, weshalb die index.htm/php doch wegfallen, oda? ^^
habs auch schon halbwegs hinbekommen, sodass momentan niemand zugriff auf den Index hat, da eine Fehlerseite angezeigt wird. ich aber demnach auch nicht -.-
ich les mich da mal ein, wie man die htaccess richtig erstellt…

benutzt den hier nehm ich immer is am leichtesten
fueralles.de/htaccess-Generator.html

^^ja den hab ich auch schon gefunden. hab nur ein kleines problem. alles schön erstellt, hoch geladen, nur verlangt er beim aufrufen der indexseite kein PW von mir, sondern zeigt folgende Fehlermeldung an:[color=#0000FF]
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@bplaced.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.[/color]

ich hab meine beiden dateien fogendermasen erstellt:
.htaccess:
AuthType Basic
AuthName "Admin"
AuthUserFile /.htpasswd
require valid-user

.htpasswd:
MeinName:MeinPW

ich denke es liegt an dem referenzieren der pass datei in der access datei -.-
mit dem “/.htpasswd” bin ich mir sehr unsicher :slight_smile:
irgendwelche vorschläge hilfe? :smiley:
thx

AuthUserFile users/benutzername/www/.htpasswd

in der .htpasswd is das passwort auch verschlüselt oder?

hm…die variante hatte ich auch schon, jetz kommt die fehlermeldung nicht nur beim aufrufen des indexes, sondern beim aufrufen aller seiten, dich ich auf meinem webspace habe…
ja PW hab ich verschlüsselt, habs ja mit einem generator erstellt…

.htacess

AuthUserFile /users/hannes/www/.htpasswd
AuthGroupFile /dev/null
AuthName "Admin"
AuthType Basic
<Limit GET>
require valid-user
</Limit>
Options -Indexes 

.htpasswd

admin:veschlüsseltes passwort

ne. index seitenaufruf führt zu fehlermeldung. wobei gesagt werden muss, dass mein Webspace nicht mit hannes sondern h4nnez erreicht wird…aber selbst als ich das geändert hatte, kam die fehlermeldung…langsam verzweifel

.htac[size=150]c[/size]ess

AuthUserFile /users/hannes/www/.htpasswd
AuthName "Admin"
AuthType Basic
<Limit GET>
require valid-user
</Limit>

.htpasswd

admin:veschlüsseltes passwort

Versuchs mal damit

Hau mich, wenn ich mich täusche, aber dann könnte ich doch den Webspace per POST noch erreichen, oder? :whata:

Nö da bringst du was durcheinander

Damit ist warscheinlich die HTTP Konversation gemeint:

[quote][size=150]GET[/size]/lustiges_verzeichniss/lustige_datei.htm,access HTTP/1.1
User-Agent: Bekiffter Browser
Host: blah.bplaced.net
Accept: text/html
Accept-Encoding: deflate, gzip, x-gzip, identity, *;q=0
Authorization: Basic xxxxxxxxxxxxxxxxxxxx
Connection: Keep-Alive, TE
TE: deflate, gzip, chunked, identity, trailers

HTTP/1.0 200 
Date: Sat, 07 Jul 2020 14:08:12 GMT
Server: Apache/0.3.6 (Unix) PHP/9.0.15
Content-length: gaaanz lang
Content-Type: text/html

<html>
<title>B&ouml;&ouml;h!</title>
<body>Der Inhalt der lustigen Seite</body>
</html>

[/quote]

Ich bringe da nix durcheinander, alles innerhalb wird nur auf GET-Requests angewendet. Wenn ich einen POST-Request absetzen würde, müsste ich kein Passwort eingeben.

Urgl… sry hab nicht mitgedacht…

Mach einfach ein daraus