CK Editor und Ajaxplorer


#1

Hallo zusammen,

ich bin mir nicht sicher ob ich hier richtig bin, falls nicht bitte verschieben. Danke. :slight_smile:

Ich hab Ajaxplorer laufen in der Version 4.2.3. Um direkt Dateien auf dem Server bearbeiten zu können habe ich den CK Editor als Plugin installiert. Lokal funktioniert auch alles einwandfrei aber wenn ich das online stelle, dann wird der CK Editor nicht geladen. Es kommt immer eine Meldung: $(…) is null

Was heisst denn diese Meldung? Ich kann den Fehler nicht finden denn lokal klappt alles problemlos nur online nicht. Kann jemand helfen?


#2

hi,

hm, bist Du denn nach einer offiziellen Installation vorgegangen? …oder evtl. davon abgewichen? Sag mal bitte Schritt für Schritt was Du genau vorgenommen hast.

ciao


#3

Hallo miro,

habe es gestern nochmal ausprobiert und ohne Änderungen hat es auf einmal wieder funktioniert. Zur Sicherheit hatte ich den CK Editor nochmal neu hochgeladen, den Browser-Cache sowie den Ordner Cache im Installationsverzeichnis bereinigt (.ser-Dateien entfernt). Ob es daran gelegen hat bezweifel ich aber, da es vor dem Fehler funktioniert hatte auch online (Lokal funktioniert alles ohne Probleme und ohne Anpassung der bootstrap_conf.php).

CK Editor gerade nochmal ausprobiert - Fehlermeldung: CK Editor is not defined

Wieder alle Caches geleert - Fehlermeldung bleibt. CK Editor wird nicht geladen.

NACHTRAG: Hab das ganze jetzt mal im IE8 ausprobiert (ich nutze sonst Firefox) und dort erscheint folgende Meldung: error loading plugins/editor.ckeditor/ckeditor/ckeditor.js?v=4.2.3:Der Vorgang konnte aufgrund des folgenden Fehlers nicht fortgesetzt werden: 80020101

Ja ich habe den Ajaxplorer ganz normal nach Anleitung installiert. das einzigste was ich machen mußte ist die bootstrap_conf.php (im conf-Ordner) anzupassen.

[code]<?php
/*

  • Copyright 2007-2011 Charles du Jeu <contact (at) cdujeu.me>
  • This file is part of AjaXplorer.
  • AjaXplorer is free software: you can redistribute it and/or modify
  • it under the terms of the GNU Affero General Public License as published by
  • the Free Software Foundation, either version 3 of the License, or
  • (at your option) any later version.
  • AjaXplorer is distributed in the hope that it will be useful,
  • but WITHOUT ANY WARRANTY; without even the implied warranty of
  • MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  • GNU Affero General Public License for more details.
  • You should have received a copy of the GNU Affero General Public License
  • along with AjaXplorer. If not, see http://www.gnu.org/licenses/.
  • The latest code can be found at http://www.ajaxplorer.info/.
  • These configuration must be set at the very root loading of the framework
    */

/*

  • If you have a charset warning, or problems displaying filenames with accented characters,
  • check your system locale and set it in the form lang_country.charset
  • Example : fr_FR.UTF-8, fr_FR.ISO-8859-1, fr_FR.CP1252 (windows), en_EN.UTF-8, etc.
  • Windows users may define an empty string
  • define(“AJXP_LOCALE”, “”);
    */
    //define(“AJXP_LOCALE”, “en_EN.UTF-8”);
    define(“AJXP_LOCALE”, “de_DE.UTF-8”);

/*

  • If you encounter problems writing to the standard php tmp directory, you can
  • define your own tmp dir here. Suggested value is ajxp_path/data/tmp/
  • AJXP_DATA_PATH, AJXP_INSTALL_PATH are replaced automatically.
  • See php.ini settings below for the session.save_path value as well.
    */
    define(“AJXP_TMP_DIR”, AJXP_DATA_PATH."/tmp");

/*

  • Additionnal php.ini settings
  • Problems with tmp dir : set your own session tmp dir (create it and make it writeable!)

  • Concurrent versions of AjaXplorer : use session.cookie_path to differentiate them.
    */
    $AJXP_INISET = array();
    $AJXP_INISET[“session.save_path”] = AJXP_DATA_PATH."/tmp/sessions";
    //$AJXP_INISET[“session.cookie_path”] = “/ajaxplorer”;

/*

  • If you want to force the https, uncomment the line below. This will automatically
  • redirect all calls to ajaxplorer via http to the same URL with https
    */
    //define(“AJXP_FORCE_SSL_REDIRECT”, true);[/code]

Ausserdem funktioniert das Pixlr-Plugin nicht (lokal kein Problem). Umleitungsfehler: Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

Woran kann das liegen?


#4

NACHTRAG: CK Editor funktioniert jetzt wieder. Im Verzeichnis des Plugins hat fast der ganze Editor gefehlt es war nur noch der Ordner plugins vorhanden obwohl ich mir sicher bin das ich den gestern komplett raufgeladen hatte.

Vieleicht war ich etwas zu müde - Nachtarbeit halt :ps:

Aber das Pixlr-Problem besteht weiterhin - Hilfe???