Contao Fehlermeldung die nur bei bplaced auftaucht


#1

Hallo liebe bplaced Community,

Ich habe mir soeben das Contao 2.11.11 bei euch installiert. Nun muss ich feststellen, dass wenn ich ein Backend Modul aufrufen will ( Einstellungsmenü ), merkwürdigerweise eine Fehlermeldung kommt die ich bei bereits verschiedensten Webspace Anbietern NICHT hatte. Als ich mir die URL der Fehlermeldung anguckte, musste ich feststellen, dass die URL auf einen Ordner verweist, der im FTP Zugang nicht vorhanden ist.
Meine Frage ist nun, ob der Fehler bei mir liegt oder ob bplaced, Contao nicht zulässt.

http://abload.de/img/errotarq4u.jpg
[size=85]Bild mit Backend Seite ( Links ) und der Fehlermeldung ( Rechts )[/size]

Ich hoffe ihr könnt mir schnell bei meinem Problem helfen. :slight_smile:


#2

Das rechts sieht irgendwie nach was aus, das die Funktion exec() benötigt, die hier nicht verfügbar ist.

Mfg :wink2:


#3

Das ist ein Bug mit ORIG_SCRIPT_NAME denke ich. Versuche mal die Funktion scriptName zu ersetzen mit (in contao-2.11.11/system/libraries/Environment.php)

[code] /**
* Return the relative path to the script (e.g. /website/index.php)
* @return string
*/
protected function scriptName()
{
return (PHP_SAPI == ‘bpmd-cgi’ || PHP_SAPI == ‘cgi’ || PHP_SAPI == ‘isapi’ || PHP_SAPI == ‘cgi-fcgi’ || PHP_SAPI == ‘fpm-fcgi’) && ($_SERVER[‘ORIG_PATH_INFO’] ? $_SERVER[‘ORIG_PATH_INFO’] : $_SERVER[‘PATH_INFO’]) ? ($_SERVER[‘ORIG_PATH_INFO’] ? $_SERVER[‘ORIG_PATH_INFO’] : $_SERVER[‘PATH_INFO’]) : ($_SERVER[‘ORIG_SCRIPT_NAME’] ? $_SERVER[‘ORIG_SCRIPT_NAME’] : $_SERVER[‘SCRIPT_NAME’]);
}

[/code]


#4

Ich habe nun den vorgeschlagenen Code von progandy mal in der Environment.php verwendet und jetzt geht alles ohne Probleme. :slight_smile: