Frage zum Domain aufschalten


#1

Hab meinen Wordpress-Blog seit einiger Zeit bei bplaced, dazu eine .de Domain mit DNS-Einstellungen gekauft => fuviblo.bplaced.de bzw. fuviblo.de
Habe im DNS-Menü die bplaced-IP angegeben und die Domain vor einigen Tagen in den bplaced-Einstellungen aufgeschaltet
Die Weiterleitung klappt auf diese Weise auch, leider ist es aber genau das… eine Weiterleitung… und keine Umbenennung der Domain… rufe ich nun www.FuViBlo.de auf, dann wird die Adresszeile umbenannt in die bplaced-URL
Ich hätt aber gern, dass alle Unterseiten als fuviblo.de/* angegeben werden, müsste doch auch möglich sein. Was hab ich da falsch gemacht bzw. welcher Schritt fehlt mir?
Danke schonmal für jegliche Hilfe


#2

Hi,

hast du deinem Wordpress auch geflüstert, dass die Stamm-URL un nicht mehr deinname.bplaced.net ist, sondern deinname.de?


#3

Das obige Problem hatte sich dann geklärt.
Ich kämpfe nun leider mit der nächsten Sache und hoffe, dass mir jemand einen Tipp geben kann.

Umfeld ist das gleiche: Webspaceadresse ist fuviblo.bplaced.de, Domain ist www.fuviblo.de
Das Aufschalten hat alles funktioniert. Wenn ich www.fuviblo.de/unterseite angezeigt. Alles wunderbar.

Wenn ich nun über die fuviblo.bplaced.de surfe, dann navigiere ich dort in den entsprechenden fuviblo.bplaced.de/Unterseiten.
Ich müsste dort dann über die htaccess die Domain umschreiben. Das versuche ich folgendermaßen

RewriteEngine on RewriteCond %{HTTP_HOST} !^www\.fuviblo\.de$ [NC] RewriteRule ^(.*)$ http://www\.fuviblo\.de/$1 [R=301,L]
Dies verursacht aber leider folgendes Problem:
rufe ich z.B. fuviblo.bplaced.de/impressum.php, dann werde ich zur richtigen .de Domain weitergeleitet. Dort lande ich allerdings immer im Home der Seite und nicht auf www.fuviblo.de/impressum.php
Dies geschieht bei jeder Unterseite.
Man müsste also irgendwas an den Rewrite-Regeln ändern, ich komm aber leider nicht dahinter.

Kann mir da jemand helfen?


#4

Also wenn ich auf deiner Website auf Impressum klicke, dann wird auch das Impressum angezeigt.


#5

Ja, naja, lies meine Problembeschreibung nochmal.
Die obige htaccess hab ich jetzt auch so drin, daher werden nachwievor alle Anfragen an die bplaced-Unterseiten auf die Hauptseite FuViBlo.de weitergeleitet (und nicht an die jeweiligen fuviblo.de-Untersteiten)… und genau das ist mein Problem.

Eben deshalb hab ich geschrieben, dass ich die htaccess richtig anpassen muss und genau da benötige ich Hilfe.


#6

In der RewriteRule Zeile solltest du die Punkte nicht mit einem \ maskieren. Dann sollte es funktionieren.


#7

Hilft scheinbar nicht.
Bei www.fuviblo.de/impressum geleitet

Sieht jetzt folgendermaßen aus

RewriteEngine on RewriteCond %{HTTP_HOST} !^www\.fuviblo\.de$ [NC] RewriteRule ^(.*)$ http://www.fuviblo.de/$1 [R=301,L]


#8

so sollte es eigentlich gehen^^
viewtopic.php?p=276022#p276022
dort habe ich auch diesen Code vorgeschlagen (bzw. mehre ausm Forum :smiley:) und es geht und ging wunderbar :stuck_out_tongue:
z.B. blendercg-de.bplaced.net/index.p … &Itemid=53 leitet wunderbar um.

Auch wenn der Code eigl. genauso ist versuch mal:

RewriteEngine on RewriteCond %{HTTP_HOST} !^fuviblo\.de$ [NC] RewriteRule ^(.*)$ http://fuviblo.de/$1 [L,R=301]bzw. wenn du nen www. davor willstRewriteEngine on RewriteCond %{HTTP_HOST} !^www\.fuviblo\.de$ [NC] RewriteRule ^(.*)$ http://www.fuviblo.de/$1 [L,R=301]und poste auch bitte mal den gesamten Code der in deiner .htaccess steht.


#9

Dein erster Codevorschlag zeigt keine Änderung, dein zweiter geht gar nicht.
Ich wundere mich auch total, nach allem was ich recherchiert habe, müsste es eigentlich funktionieren, ich verstehs nicht.
Die gesamte htaccess schicke ich dir mal per PM.


#10

Problem gelöst, danke White-Tiger


#11

Vielen Dank, es hat wunderbar geklappt. Allerdings habe ich jetzt das Problem, dass ich mich nicht mehr über das wp-admin ins Wordpress Backend einloggen kann. Was kann ich tun oder muss ich noch anpassen? Vielen Dank


#12

Wenn ich mich nicht irre hast du vergessen Wordpress zu sagen welche Domain / URL es jetzt nutzt…
In dem Fall würde ich die umleitung in der .htaccess wieder deaktivieren und im Wordpress die Domain umstellen, erst wenn das dann funktioniert wieder die .htaccess umleitung aktiv setzen.

Die 2 zu ändernden settings findest du in Wordpress unter: Einstellungen => Allgemein

Ggf. ist es in deinem Fall aber besser die Domain in der Datenbank direkt zu editieren… bzw. ggf. das Wordpress plugin Duplicator zu benutzen.


#13

Hi! Habe die Domain unter Einstellungen im Wordpress geändert. Daraufhin konnte ich mich nicht mehr über das Backend einloggen, da ich das Redirect-Problem hatte. Daraufhon habe ich in der wp-config.php die seiten URL erneutert und es klappte wieder. Seitdem ich die htacces angepasst habe geht es wieder nicht, auch wenn ich den Eintrag aus der wp-config.php entferne. Was kann ich tun? Wie kann ich die Domain in der Datenbank editieren? Vielen Dank


#14

Das hört sich so eher danach an, dass die Domain nicht aufgeschaltet wurde… kannst du mir deinen bplaced nutzer + Wordpress adresse + aufzuschaltene Domain via PM nennen?
Am besten auch noch den inhalt deiner .htaccess