[gelöst ]drupal 7 - bilder werden nicht angezeigt

Liebe bplaced-community,
nach der erfolgreichen Drupa7-Installation funktioniert soweit alles ok…
Allerdings habe ich dann festgestellt, dass keine Bilder angezeigt werden, wenn ich z.B. in einem Beitrag ein Bild einfüge/hochlade oder im Benutzerkonto ein Benutzerbild hochlade…
Ich habe auch schon folgenden Beitrag gefunden: viewtopic.php?f=13&t=17621&p=325175&hilit=drupal#p325175
…und auch die Änderungen in der .htaccess ausprobiert. Leider ohne Erfolg! :neutral_face:
Die hochgeladenen Bilder sind zwar anschließend im FTP-Verzeichnis, aber wenn ich auf der Seite mit Firebug nachsehe, dann ist der angegebene Pfad/Link zum Bild anders… o.0

Hier noch schnell der Link zu meiner Site: mootown.bplaced.net/
Und der Inhalt der .htaccess:


Apache/PHP/Drupal settings:

Protect files and directories from prying eyes.

<FilesMatch „.(engine|inc|info|install|make|module|profile|test|po|sh|.sql|theme|tpl(.php)?|xtmpl)$|^(…|Entries.*|Repository|Root|Tag|Template)$“>
Order allow,deny

Don’t show directory listings for URLs which map to a directory.

Options -Indexes

Multiviews creates problems with aliased URLs and is not needed for Drupal.

Options -Multiviews

Make Drupal handle any 404 errors.

ErrorDocument 404 /index.php

Force simple error message for requests for non-existent favicon.ico.

# There is no end quote below, for compatibility with Apache 1.3. ErrorDocument 404 "The requested file favicon.ico was not found.

Set the default handler.

DirectoryIndex index.php index.html index.htm

Override PHP settings that cannot be changed at runtime. See

sites/default/default.settings.php and drupal_initialize_variables() in

includes/bootstrap.inc for settings that can be changed at runtime.

PHP 5, Apache 1 and 2.

php_flag magic_quotes_gpc off php_flag magic_quotes_sybase off php_flag register_globals off php_flag session.auto_start off php_value mbstring.http_input pass php_value mbstring.http_output pass php_flag mbstring.encoding_translation off

Requires mod_expires to be enabled.

# Enable expirations. ExpiresActive On

Cache all files for 2 weeks after access (A).

ExpiresDefault A1209600

<FilesMatch .php$>
# Do not allow PHP scripts to be cached unless they explicitly send cache
# headers themselves. Otherwise all scripts would have to overwrite the
# headers set by mod_expires if they want another caching behavior. This may
# fail if an error occurs early in the bootstrap process, and it may cause
# problems if a non-Drupal PHP file is installed in a subdirectory.
ExpiresActive Off

Various rewrite rules.

RewriteEngine on

Block access to „hidden“ directories whose names begin with a period. This

includes directories used by version control systems such as Subversion or

Git to store control files. Files whose names begin with a period, as well

as the control files used by CVS, are protected by the FilesMatch directive


NOTE: This only works when mod_rewrite is loaded. Without mod_rewrite, it is

not possible to block access to entire directories from .htaccess, because

is not allowed here.

If you do not have mod_rewrite installed, you should remove these

directories from your webroot or otherwise protect them from being


RewriteRule „(^|/).“ - [F]

If your site can be accessed both with and without the ‚www.‘ prefix, you

can use one of the following settings to redirect users to your preferred

URL, either WITH or WITHOUT the ‚www.‘ prefix. Choose ONLY one option:

To redirect all users to access the site WITH the ‚www.‘ prefix,

(http://example.com/… will be redirected to http://www.example.com/…)

uncomment the following:

RewriteCond %{HTTP_HOST} !^www. [NC]

RewriteRule ^ http://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

To redirect all users to access the site WITHOUT the ‚www.‘ prefix,

(http://www.example.com/… will be redirected to http://example.com/…)

uncomment the following:

RewriteCond %{HTTP_HOST} ^www.(.+)$ [NC]

RewriteRule ^ http://%1%{REQUEST_URI} [L,R=301]

Modify the RewriteBase if you are using Drupal in a subdirectory or in a

VirtualDocumentRoot and the rewrite rules are not working properly.

For example if your site is at http://example.com/drupal uncomment and

modify the following line:

RewriteBase /drupal

If your site is running in a VirtualDocumentRoot at http://example.com/,

uncomment the following line:

RewriteBase /

Pass all requests not referring directly to files in the filesystem to

index.php. Clean URLs are handled in drupal_environment_initialize().

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !=/favicon.ico
RewriteRule ^ index.php [L]

Rules to correctly serve gzip compressed CSS and JS files.

Requires both mod_rewrite and mod_headers to be enabled.

# Serve gzip compressed CSS files if they exist and the client accepts gzip. RewriteCond %{HTTP:Accept-encoding} gzip RewriteCond %{REQUEST_FILENAME}\.gz -s RewriteRule ^(.*)\.css $1\.css\.gz [QSA]
# Serve gzip compressed JS files if they exist and the client accepts gzip.
RewriteCond %{HTTP:Accept-encoding} gzip
RewriteCond %{REQUEST_FILENAME}\.gz -s
RewriteRule ^(.*)\.js $1\.js\.gz [QSA]

# Serve correct content types, and prevent mod_deflate double gzip.
RewriteRule \.css\.gz$ - [T=text/css,E=no-gzip:1]
RewriteRule \.js\.gz$ - [T=text/javascript,E=no-gzip:1]

<FilesMatch "(\.js\.gz|\.css\.gz)$">
  # Serve correct encoding type.
  Header append Content-Encoding gzip
  # Force proxies to cache gzipped & non-gzipped css/js files separately.
  Header append Vary Accept-Encoding

$Id: .htaccess,v 1.111 2010/11/23 02:59:05 dries Exp $


Ich würde mich über Ideen/Hilfe sehr freuen!
Ich danke schon mal im Voraus!
Grüße mozinho

Ich kämpfe im Moment mit genau demselben Problem.

Unter configuration -> Media -> file system kann man den relativen Pfad für die files setzen. Dieser lautet normalerweise sites/default/files .

Doch leider tut es nicht, obwohl die Bilder durchaus da sind :neutral_face:

bei mir hat es geholfen die die Zeile der “zweiten” .htaccess-Datei unter …/sites/default/files

auszukommentieren, also so

Hier auch der andere Beitrag dazu: viewtopic.php?f=13&t=17621&hilit=drupal&start=10

Danke ans “Forum”!!! Top! :wink:
Grüße mozinho

Jaa!! Herzlichen Dank :wink2: