Internal Server Error with .htaccess

Hi, i must tell i was looking for an english thread with similar problem with mine - without result.
So i want to turn off ‘magic_quotes_gpc’ with .htaccess file. My .htaccess look like this: ‘php_flag magic_quotes_gpc off’. When .htaccess isn’t empty my page has internal server error. What should i do?

you cannot change anything related to PHP in .htaccess since PHP is running as CGI
but you can change it by using a .user.ini/.php.ini file :wink: [size=85](Google for it, it was added in PHP 5.3 i believe, .user.ini is the right name, .php.ini is also working here)[/size]
Or just turn it of in all your scripts^^

Thank you for answer. Do you know path of php.ini file? : |

The .user.ini-file (remind the first dot) should be placed in directories to which these settings are to be applied.


just put a file named .php.ini (there is a dot as first character!) in any directory you wish the effect for, including one line,

magic_quotes_gpc = off


magic_quotes_gpc = off
[][/quote]shouldn’t it bemagic_quotes_gpc = Off? :ps:

get some glasses, I never wrote that.

you never wrote what?

PS: PHP itself writes the “O” uppercase so it’s better to do the same.

Check the sources. It says I don't care.

Thank you for help, it works :smiley: