Joomla 3.1.x - Installationsanleitung


#1

hallo,

bei der Installation von Joomla 3.1.x gibt es zur Zeit das Problem, dass nach dem ersten Schritt der Installation der Ladebalken erscheint aber der Vorgang kein Ende findet. Eine Lösung dazu gibt es im offiziellen Support-Forum von Joomla:

forum.joomla.org/viewtopic.php?f=707&t=807540

Die Installation funktioniert danach einwandfrei. :wink:

Eine Installation von Joomla 2.5.x wird nicht mehr empfohlen.


#2

hallo,

im Versionenzweig 3.1.x befindet sich eine XSS-Lücke welche für Schaden sorgen kann. Bis die Lücke mit der Version 3.1.6 geschlossen wird (Release wird in diesen Tagen erwartet) kann man einfach folgende Datei vom Webserver entfernen um so sein Joomla sicher zu halten;

[quote]/libraries/idna_convert/example.php
[/quote]
Dies ist eine Drittanbieter-Entwicklung und für die Nutzung von Joomla (Joomla Kern) nicht erforderlich.


#3

[quote=“fusl”]hallo,

bei der Installation von Joomla 3.1.x gibt es zur Zeit das Problem, dass nach dem ersten Schritt der Installation der Ladebalken erscheint aber der Vorgang kein Ende findet. Eine Lösung dazu gibt es im offiziellen Support-Forum von Joomla:

forum.joomla.org/viewtopic.php?f=707&t=807540

Die Installation funktioniert danach einwandfrei. :wink:

Eine Installation von Joomla 2.5.x wird nicht mehr empfohlen.[/quote]

Wer kann einem alten Mann :slight_smile: (65 Jahre) sagen was das auf deutsch heißt?
Kann leider kein englisch.
Ich sage jedem schon heute DANKE

Udo


#4

hallo,

also, suche via Filezilla oder einem anderen FTP Programm die Datei installation/application/framework.php.
Danach machst du einen Rechtsklick und gehst auf “Ansehen/Bearbeiten” - die Datei
müsste sich dann in einem gängigen Editor öffnen.

Dort suchst du die Stelle mit …

ini_set(‘display_errors’, true);

und änderst diese auf …

ini_set(‘display_errors’, false);

Danach einfach die Datei auf dem Server abspeichern und die Installation erneut aufrufen.
Der AJAX-Fehler ist dann behoben und das nächste Installationsfenster öffnet sich.


#5

[quote=“fusl”]hallo,

also, suche via Filezilla oder einem anderen FTP Programm die Datei installation/application/framework.php.
Danach machst du einen Rechtsklick und gehst auf “Ansehen/Bearbeiten” - die Datei
müsste sich dann in einem gängigen Editor öffnen.

Dort suchst du die Stelle mit …

ini_set(‘display_errors’, true);

und änderst diese auf …

ini_set(‘display_errors’, false);

Danach einfach die Datei auf dem Server abspeichern und die Installation erneut aufrufen.
Der AJAX-Fehler ist dann behoben und das nächste Installationsfenster öffnet sich.[/quote]

Tausend DANK
Es klappt
Ich bin begeistert über die schnelle Hilfe


#6

Bei mir kommt, wenn ich alles eingegeben habe, eine Fehlermeldung mit der Aufforderung die Pflichtfelder komplett auszufüllen. Trotz des Tipps hat es bei mir nicht Funktioniert :frowning:


#7

hallo,

lade bitte die Datei framework.php nochmals frisch von ’ Joomla.org ’ herunter und führe den Bugfix genau so wie in meinem Beitrag beschrieben aus, du hast bei deinem Versuch wohl zu viele Werte aus der Datei entfernt. Dies führt aktuell dazu, dass eine Installation gar nicht möglich ist.