Ordner unsichtbar


#1

Servus Leute,

leider nochmal ein Problem. (Oh je, schon zwei Probleme kurz hintereinander !)
Also, ich habe per FTP meinen Magento Installationsordner hochgeladen, soweit - sogut.
Leider wird der mir wenn ich über www auf diesen zugreifen möchte, NICHT angezeigt. Als wäre er unsichtbar…per FTP sehe ich diesen aber.

So ein ähnliches Problem habe ich auf meinem localhost mit dem Ordner Veyton gehabt, alle Ordner waren prima sichtbar nur der auf meinem localhost liegender Ordner Veyton war unaufrufbar.

Tipps ?

Danke.


#2

Hi,

hast du zufällig vor dem ordner einen punkt ? bzw. hast du den ordner in nen anderen Ordner mit rein geschoben (z.b.: MySQLAdmin oder PGSQLadmin) …

lg flo

Ansonsten mach Screenshots vom FTP und poste nen link von deiner seite (auch wenn der account im profil drin steht aber machts für uns nur aufwendiger :wink: )

Oder ich kann dir auch via Teamviewer helfen oder Skype Bildschirm übertragung (daflo95)


#3

Hallo,

vielen Dank für deine Hilfe.
Der Link:
alexmsi.bplaced.net/

Screenshot vom Server:


#4

Da wird wohl eine falsch konfigurierte .htaccess im Ordner Magento liegen. Beim direkten Aufruf kommt ein “Internal Server Error”

Außerdem solltest du daran denken, dass hier Magento ungleich magento ist, es wird die Groß/Kleinschreibung beachtet.


#5

Die htacess ist standart.
Groß-/Kleinschreibung hilft nicht.

Wenn ich es über den Downloader installieren möchte, verlangt er nach einer “PHP Extension curl must be loaded”.

:confused:

Jedoch habe ich leider keinen php.ini zugang.

Mist !


#6

HAllo,

wie ist denn der Inhalt der .htaccess Datei?


#7

[code]############################################

uncomment these lines for CGI mode

make sure to specify the correct cgi php binary file name

it might be /cgi-bin/php-cgi

Action php5-cgi /cgi-bin/php5-cgi

AddHandler php5-cgi .php

############################################

GoDaddy specific options

Options -MultiViews

you might also need to add this line to php.ini

cgi.fix_pathinfo = 1

if it still doesn’t work, rename php.ini to php5.ini

############################################

this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################

default index file

DirectoryIndex index.php

############################################

adjust memory limit

php_value memory_limit 64M

php_value memory_limit 128M
php_value max_execution_time 18000

############################################

disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################

disable automatic session start

before autoload was initialized

php_flag session.auto_start off

############################################

enable resulting html compression

#php_flag zlib.output_compression on

###########################################

disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################

turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off
########################################### # disable POST processing to not break multiple image upload
SecFilterEngine Off
SecFilterScanPOST Off

############################################

enable apache served files compression

http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
#AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems...
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don't compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don't deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

############################################

make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

############################################

enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################

you can put here your magento root folder

path relative to web root

#RewriteBase /magento/

############################################

workaround for HTTP authorization

in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################

always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################

never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################

rewrite everything else to index.php

RewriteRule .* index.php [L]

############################################

Prevent character encoding issues from server overrides

If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

############################################

Add default Expires header

http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault "access plus 1 year"

############################################

By default allow all access

Order allow,deny
Allow from all

############################################

If running in cluster environment, uncomment this

http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

[/code]

Bitteschön !:wink:

Habe nun Veyton auf meinen Server hochgeladen. Der Ordner wird aufjedenfall schonmal angezeigt. Bei mir auf dem Localhost ist es exakt umgekehrt. Da wird Veyton nicht angezeigt, Magento schon…


#8

Hallo,

ich sehe in deiner .htaccess
Options +FollowSymLinks

Setze bitte davor noch ein kleines Zeichen: #

Die Zeile sollte dann so aussehen:


#9

Du bist mein Held !:-*

Würdest du mir nun auch verraten, woran es lag ? Bzw. was bewirkt die funktion ? Hat sie evtl. irgendwelche Auswirkungen auf die Installation ?

EDIT:

Ach, mist :frowning:
Er verlangt immernoch nach der “PHP extension “curl” must be loaded.”. Diese funktion lässt sich jedoch nur in der php.ini verändern.
Habt ihr die Möglichkeit sowas zu tun ? (extension=php_curl.dll)
Ich hoffe, dass die Installation nun nicht daran scheitert. Endlich einen guten Hoster gefunden.

Danke! :slight_smile:


#10

dll auf linux?


#11

Hi,

curl = externe Verbindungen oder verwechsel ich da grad was?

Wenn des stimmt dann:
[ul]
[li]bplaced Pro (3 Euro Monat)[/li]
[li]square7[/li][/ul]

lg flo


#12

CURL gibt es nur in bplaced pro. Bei square7 gibt es das auch im kostenlosen Paket, dafür musst du aber mit Werbe-Popunder leben.


#13

Gekauft =)

Wie aktiviere ich nun die Curl ?


#14

Hallo,

freut mich, dass du nun bplaced pro Nutzer bist.
Du musst selber nichts aktivieren, es geht nach dem Kauf und dem Geldeingang bei uns etwa 30 Minuten bis alles übernommen wurde, ab diesem Zeitpunkt ist es dann automatisch aktiviert und kann verwendet werden. :slight_smile:

Gruss