PIWIK Funtioniert nicht richtig


#1

Ich habe auf meine Webspace versucht PIWIK zu installieren leider funktioniert dies nicht
Der error der angezeigt wird ist
"WP-Piwik 1.0.8 konnte sich mit Deiner Konfiguration nicht mit Piwik verbinden. Bitte überprüfe die »Mit Piwik verbinden«-Sektion unten."

Vielen Dank für Eure Hilfe.

ich habe mal das tests skript ausgeführt:
`WP-Piwik 1.0.8
Mode: http

Test 1/3: global.getPiwikVersion

.bpe a:link, .bpe a:visited, .bpe a:active { color: #0b4c8e; text-decoration: none; } .bpe a:hover { color: #0D7CEC; }



Warning: get_headers() has been disabled for security reasons in /users/mind-life/www/wp-content/plugins/wp-piwik/classes/WP_Piwik/Request/Rest.php on line 69

bool(false)

array(2) {
[0]=>
NULL
[1]=>
string(115) “/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3De&token_auth=…”
}

Test 2/3: SitesManager.getSitesWithAtLeastViewAccess

.bpe a:link, .bpe a:visited, .bpe a:active { color: #0b4c8e; text-decoration: none; } .bpe a:hover { color: #0D7CEC; }



Warning: get_headers() has been disabled for security reasons in /users/mind-life/www/wp-content/plugins/wp-piwik/classes/WP_Piwik/Request/Rest.php on line 69

bool(false)

array(2) {
[0]=>
NULL
[1]=>
string(188) “/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3De&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3De&token_auth=…”
}

Test 3/3: SitesManager.getSitesIdFromSiteUrl

.bpe a:link, .bpe a:visited, .bpe a:active { color: #0b4c8e; text-decoration: none; } .bpe a:hover { color: #0D7CEC; }



Warning: get_headers() has been disabled for security reasons in /users/mind-life/www/wp-content/plugins/wp-piwik/classes/WP_Piwik/Request/Rest.php on line 69

bool(false)

array(2) {
[0]=>
NULL
[1]=>
string(296) “/?module=API&method=API.getBulkRequest&format=json&urls[0]=method%3DAPI.getPiwikVersion%26idSite%3De&urls[1]=method%3DSitesManager.getSitesWithAtLeastViewAccess%26idSite%3De&urls[2]=method%3DSitesManager.getSitesIdFromSiteUrl%26idSite%3De%26url%3Dhttp%3A%2F%2Fmind-life.bplaced.net&token_auth=…”
}

array(2) {
[“global_settings”]=>
array(58) {
[“revision”]=>
string(10) “2016040501”
[“last_settings_update”]=>
string(10) “1465925195”
[“piwik_mode”]=>
string(4) “http”
[“piwik_url”]=>
string(1) “/”
[“piwik_path”]=>
string(26) “/user/mind-life/www/piwik/”
[“piwik_user”]=>
string(0) “”
[“piwik_token”]=>
string(3) “set”
[“auto_site_config”]=>
string(1) “1”
[“default_date”]=>
string(9) “yesterday”
[“stats_seo”]=>
string(1) “0”
[“dashboard_widget”]=>
string(8) “disabled”
[“dashboard_chart”]=>
string(1) “0”
[“dashboard_seo”]=>
string(1) “0”
[“toolbar”]=>
string(1) “0”
[“capability_read_stats”]=>
array(5) {
[“administrator”]=>
string(1) “1”
[“editor”]=>
string(1) “0”
[“author”]=>
string(1) “0”
[“contributor”]=>
string(1) “0”
[“subscriber”]=>
string(1) “0”
}
[“perpost_stats”]=>
string(1) “0”
[“plugin_display_name”]=>
string(8) “WP-Piwik”
[“piwik_shortcut”]=>
string(1) “0”
[“shortcodes”]=>
string(1) “0”
[“track_mode”]=>
string(8) “disabled”
[“track_codeposition”]=>
string(6) “footer”
[“track_noscript”]=>
string(1) “0”
[“track_nojavascript”]=>
string(1) “0”
[“proxy_url”]=>
string(0) “”
[“track_content”]=>
string(8) “disabled”
[“track_search”]=>
string(1) “0”
[“track_404”]=>
string(1) “0”
[“add_post_annotations”]=>
string(1) “0”
[“add_customvars_box”]=>
string(1) “0”
[“add_download_extensions”]=>
string(0) “”
[“set_download_extensions”]=>
string(0) “”
[“disable_cookies”]=>
string(1) “0”
[“limit_cookies”]=>
string(1) “0”
[“limit_cookies_visitor”]=>
string(8) “34186669”
[“limit_cookies_session”]=>
string(4) “1800”
[“limit_cookies_referral”]=>
string(8) “15778463”
[“track_admin”]=>
string(1) “0”
[“capability_stealth”]=>
array(0) {
}
[“track_across”]=>
string(1) “0”
[“track_across_alias”]=>
string(1) “0”
[“track_feed”]=>
string(1) “0”
[“track_feed_addcampaign”]=>
string(1) “0”
[“track_feed_campaign”]=>
string(4) “feed”
[“track_heartbeat”]=>
string(1) “0”
[“track_user_id”]=>
string(8) “disabled”
[“cache”]=>
string(1) “1”
[“http_connection”]=>
string(4) “curl”
[“http_method”]=>
string(4) “post”
[“disable_timelimit”]=>
string(1) “0”
[“connection_timeout”]=>
string(1) “5”
[“disable_ssl_verify”]=>
string(1) “0”
[“piwik_useragent”]=>
string(3) “php”
[“piwik_useragent_string”]=>
string(8) “WP-Piwik”
[“track_datacfasync”]=>
string(1) “0”
[“track_cdnurl”]=>
string(0) “”
[“track_cdnurlssl”]=>
string(0) “”
[“force_protocol”]=>
string(8) “disabled”
[“update_notice”]=>
string(7) “enabled”
}
[“settings”]=>
array(6) {
[“name”]=>
string(0) “”
[“site_id”]=>
string(1) “e”
[“noscript_code”]=>
string(0) “”
[“tracking_code”]=>
string(0) “”
[“last_tracking_code_update”]=>
string(1) “0”
[“dashboard_revision”]=>
string(1) “0”
}
}
`


#2

Das liegt daran, dass die get_headers() Funktion deaktiviert ist. Vermutlich schafft hier ein bplaced pro Konto Abhilfe.


#3

Schon mal danke für deine Hilfe, heavygale; Was räts du mir also als Tipp um PIWIKI zum laufen zu kriegen? oder was meinst du mit “bplaced pro Konto Abhilfe”


#4

bplaced pro ist die Kostenpflichtige Variante von bplaced.
Ich vermute, dass die Funktion dort nicht deaktiviert ist.
Du hast also folgende Optionen:

-> Ein kostenpflichtiges Konto registrieren (vorher den Support fragen, ob dort get_headers() verfügbar ist).
-> Einen anderen Webhosting-Anbieter suchen, bei dem die Funktion nicht deaktiviert ist. (Tipps auf Nachfrage per PN)
-> Piwik-Hosting bei einem entsprechenden Dienstleister buchen. (Oder mir eine PN schreiben grins)
-> Auf Piwik verzichten.


#5

Warum lässt du Piwik nicht unabhängig von Wordpress laufen? Das funktioniert auf jeden Fall auch ohne Sockets.