Probleme mit <div> & <iframe> im IE

Guten Morgen,

hab ein kleines Problem mit dem ungeliebten IE6/7.
Ich habe mein Content-iFrame in ein

gepackt, damit ich das skalieren kann, leider hat der IE damit massive Probleme.

Vl. kann mir einer von Euch da weiterhelfen.

Homepage: clooney.bplaced.net/ortwein-gmbh/

mfg Clooney

Mag vermutlich sein, daß das dem MSIE ziemlich egal ist, aber
falsch ist es trotzdem:
Bei dem verwendeten doctype gibt es kein Element iframe und
img hat auch kein Attribut border, eine Endmarkierung hat img
in HTML auch nicht, da ist das einfach ein leeres Element.
a hat kein Attribut target.

Zum CSS:
bottom: 30 !important; ist falsch, da fehlt die Angabe einer
Einheit, das kann allgemein Probleme bereiten.
filter:Alpha(Opacity=90); ist falsch, zwar gibt es für SVG eine
Eigenschaft filter, die hat haber ganz andere Werte - also ganz
streichen.
Anderes wie die Angabe von font-size in px ist zumindest
schlecht, weil der Nutzer ja bereits eine für ihn optimale
Schriftgröße an seinem browser eingestellt haben sollte.

Zum Problem der Dimensionierung: Zumindest beim MSIE6 habe
ich auch schon früher mal festgestellt, daß der Probleme hat,
wenn Höhe/Breite eines Elternelements nur implizit festliegen,
darin Prozentangaben für die Höhe/Breite sinnvoll zu
interpretieren. Ausweg ist zum Beispiel, per ‘conditional
comments’ eine weitere CSS-Datei für den anzubieten, wo die
Höhe/Breite explizit festgelegt wird - zwar nicht schön, den Inhalt
kann man sich dann mit dem browser immer noch irgendwie
angucken. Besser ohnehin, ganz auf den iframe zu verzichten und
den Inhalt direkt in die eigentliche Seite einzubinden, da treten
solche Probleme nicht auf, weil sich die Seite da gleich so weit
vergrößert, daß der Inhalt reinpaßt.

Ich glaub ich habs hinbekommen.

Wer will kann sich die Lösung ja mal anschaunen.
clooney.bplaced.net/ortwein-gmbh/test.php

@hoffman: ist nicht elegant gelöst, aber es tut.

was genau war denn dein problem?