Probleme mit externer Festplatte

Hallo,

ich habe ein Problem mit meiner externen Festplatte (WD Elements 1,5 TB). Unter Windows 7 möchte er meine Festplatte formatieren, was sehr ungelegen ist, da ich viele wichtige Daten darauf gespeichert habe. Mit Ubuntu (11.04) kann ich die Festplatte nicht öffnen/ einhängen:

Leider sagt mir das nicht wirklich viel, außer das meine Festplatte wohl defekt ist.
Hier ist das Ergebnis von “sudo fdisk -l”:

Hat jemand eine Idee, wie ich das Problem lösen kann? Kann ich meine Daten noch retten?

Vielleicht mal so was ausprobieren:

pcinspector.de/

Also ganz ehrlich: ich glaub die Daten sind weg! Ich hatte das auch mal und habe wirklich alles probiert um meine Bilder zu retten und musste dabei feststellen, dass die meisten Angebote im Internet unseriös sind und wenn mal was dabei ist, kann man nur beschädigte Dateien wiederherstellen mit denen man eh nichts anfangen kann! Da muss wohl eine neue Festplatte her!

ich persönlich hatte ebenfalls das problem, dass windows die platte immer formatieren wollte - mein “lösung” wird dir nur leider nicht viel helfen, denn nachdem ich es einmal an ein linux (glaube ubuntu karmic wars) angeschlossen hatte gings wieder (auch unter windows)…

Da Linux dir ja sagt das die Partitionstabelle defekt scheint frage ich mich, ob du deine externe Platte unter Windows immer erst dann anschließt, wenn du dich eingeloggt hast, oder schon mit dem Bootvorgang?

Theoretisch würde Windows beim Bootvorgang nämlich feststellen, dass i-was mit der PLatte nicht stimmt und versuchen via Checkdisk die Probleme zu lösen. Alternativ kann man das natürlich auch im laufenden Betrieb tun, indem man eine Komandozeile öffnet (CMD)

Unter WinXP: Start -> Ausführen und “CMD” eingeben
Unter Win7: Start “CMD” in das Suchfeld eingeben und dann mit rechtsklick auf cmd und als admin ausführen, sonst hast du nicht ausreichend rechte dafür.

dann tippst du ins cmd-fenster einfach “CHKDSK /F /V :” der doppelpunkt hinter dem laufwerksbuchstaben is wichtig. Hoffe dass das klappt ^^

Ich habe die Festplatte wieder zum Laufen gebracht. Besser gesagt ich habe es nochmal unter Windows 7 probiert, wo er mir erneut sagte, ich solle sie formatieren. Dann habe ich sie nochmal in Ubuntu angeschlossen und eingehängt und siehe da kein Fehler mehr da. Auch unter 7 kein Problem mehr.

Danke (trotzdem) für die vielen Antworten.

Wenn du Linux-Diagnoseinfos verwendest hilft es oft auch den syslog auch anzusehen, da steht nämlich genau drinnen welche Schritte bei der Initialisierung funktioniert haben und welche nicht.