Verbindung nur von außen?


#1

Hallo,

ich weiß garnicht, wie ich das Thema hier titulieren soll. Es geht um meinen Apache2 Webserver auf meinem Raspi. Hab gestern wieder mal etwas per SFTP auf meinen Server geladen und wollte es im Browser abrufen, das ging aber nicht. Auf den Raspi läuft ein Webserver aber zwei Domains, die ganzen Hosts und Subdomains sind unter /etc/apache2/sites-enabled/ gespeichert. foobar1.de ist in der 000-default definiert und läuft auf /var/www/foobar1/; foobar2.de ist in der 998-foobar2 definiert und läuft auf /var/www/foobar2/.

Per FileZilla hatte ich keine Probleme, erst beim Abrufen unter foobar2.de fiel mir auf, dass der Server keine Antwort schickt. In Chrome sah das dann so aus:

[code]Diese Webseite ist nicht verfügbar.

DNS_PROBE_FINISHED_NXDOMAIN
Der Server unter foobar2.de kann nicht gefunden werden, weil die DNS-Suche fehlgeschlagen ist. […][/code]
Als ich die selben Daten auf foobar1.de abrufen wollte, ging es. Ich hab die Datei natürlich in beiden Ordnern hochgeladen.

Im Domain-Manager sind beide Domains aktiv, no-ip hat die aktuelle IP von meinem Router bekommen und wenn ich Apache2 neustarte erhalte ich keinen Fehler. Mein Server läuft mit einer variablen IP, hab daher ein System aus no-ip und bind9, das die aktuelle IP in mein System bringt.

Zwischenzeitlich konnte ich bei foobar2.de auf die Datei zugreifen, dann war der Server aber auch wieder nicht erreichbar.
Ich kann also von Zuhause von mehreren Systemen nicht auf foobar2.de zugreifen, andere Freunde können aber auf beide Domains zugreifen (ich habe 4 Leute befragt).

downforeveryoneorjustme.com/ meint bei beiden Seiten, dass sie wohl down wären und eine Freundin, der ich einen Link zu einer Datei auf foobar2.de geschickt habe, meinte dass der Link nicht gehen würde.

Als ich auf meine no-ip-Seite zugreifen wollte, hat Chrome wieder gemeckert.

[code]Diese Webseite ist nicht verfügbar.

ERR_CONNECTION_TIMED_OUT
Google Chrome konnte die Webseite nicht laden, weil foobar1.ddns.net zu lange zum Antworten benötigt.[/code]
Ich weiß echt nicht, was hier los ist. Hab wegen Cache extra mit neuen Dateien probiert, aber eig. kann es daran nicht liegen. Angeblich sollen Dateien auf foobar2.de auch schneller laden als auf foobar1.de (bestätigt durch 2 Personen), was für mich auch keinen Sinn ergibt, da ja alles auf dem selben Server läuft. Könnte das an den Dateinamen (000-blah, 998-blah) liegen?

Habt ihr schon einmal ein ähnliches Problem gehabt? Ich wäre froh um Hilfe, vielen Dank bereits im Voraus!

Gruß, DMan


#2

Sehr interessant, leider kann ich nicht helfen hatte so ein Problem noch nie. Wenn dann konnte niemand zugreifen. Hast du mal das Problem beim Serveranbieter angefragt?


#3

Der Raspi steht bei mir im Zimmer. ^^


#4

Hallo,
das liegt vermutlich am Router, da der die IP nicht auflösen kann.
Ist bei mir zu hause genau gleich…

Grüße
Sebastian


#5

Sind foobar1.de/foobar2.de echte domains? wenn nicht, würde es nicht einfach ausreichen die domains in deiner lokalen hosts datei mit der entsprechenden IP deines raspis einzutragen? (/etc/hosts oder C:\Windows\system32\drivers\etc\hosts oder so ähnlich)


#6

Ja, sind sie. Sie sollen von außen für jeden zugänglich sein. (Ich denke mal, dass du das meinst).

Aber ich glaube ich habe die Lösung gefunden. In einem Unterordner von foobar2.de lag eine korrupte Index-Datei (über 50 MB groß). puu.sh/jRul9/10b9e02f00.png
Als ich die entfernt hatte, schien alles wieder normal. Wie diese korrpute Datei zu Stande kam, keine Ahnung. Aber bei mir ist vieles nicht erklärbar. :smiley:

Danke für die Hilfe.

Gruß, DMan


#7

Die “korrupte Index Datei” war möglicherweise ein PNG Bild. ganz unten sehe ich einen IEND chunk, was das ende eine PNG Datei signalisiert.


#8

gleiches DNS_PROBE_FINISHED_NXDOMAIN Problem


#9

so ist, dann suche ich nach Lösungen im Internet und fand eine Webseite
http://www.deskdecode.com/dns_probe_finished_nxdomain/
und nach dem Versuch, einige Schritte
mein ganzes Internet wird nach unten
kann i’me verurteilt
bitte helfen