Verbindung zur Datenbank geht nicht

Leider bekomme ich für meine Abfrage keine Verbindung zur Datenbank.
Es sind alle Seiten ect. auf dem Server hochgeladen.

Fehlermeldung:

 Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'momoblue86'@'localhost' (using password: YES) in /users/momoblue86/www/Memorio/Hauptlinks/Haupt/DerStall/db.php on line 11
Keine Verbindung möglich

Code für die DB Verbindung

<?php /*Hostname oder IP des MySQL-Servers */ $sqlhost = "localhost"; /*Username und Passwort */ $sqluser = "momoblue86"; $sqlpassword = "pass*"; /* Name der Datenbank */ $sqldb = "momoblue86"; /*Verbindung herstellen */ mysql_connect("$sqlhost","$sqluser","$sqlpassword") or die ("Keine Verbindung möglich"); mysql_select_db("$sqldb") or die ("Die Datenbank existiert nicht"); ?>

Code von der PHP seite zur abfragung und ausgebung

<?php // Verbindung zur Datenbank include("db.php"); // Hier die Abfrage übersetzt: RUFE * (alle Spalten) VON der Tabelle Pferd auf WO in der Spalte Besitzer nichts steht. $Ergebnis = mysql_query("SELECT * FROM `Pferde` Where Kathegorie = 'Rentner' Order by Name"); // Wenn das Ergebnis 0 ist gib aus if (@mysql_num_rows($Ergebnis) == 0) { echo "

Zur Zeit haben wir keine
Rentner"; } else { // Sonst zeige an .. while($Data = mysql_fetch_array($Ergebnis)) { // Der Steckbriefname lautet Pferd. Diesem wird jetzt die ID des Pferdes angehängt, damit die Datei nachher weiß, welche Daten sie abfragen muss. // Ihr könnt die ganzen anderen Infos auch angeben .. sprich $Data[Jahrgang] oder $Data[Geschlecht] echo " $Data[Name] $Data[Farbe] $Data[Jahrgang] $Data[Schwerpunkt] $Data[Vater]
$Data[Mutter] "; } } ?>

kann mir jemand helfen?
Ich ziehe gerade auf bplaced um. vorher hat alles funktioniert.
Auch benutzname und passwort sind richtig eingegeben.
Leider finde ich den fehler nicht

Hast du die Datenbank auch zuvor angelegt?

hi

das angegebene Passwort stimmt nicht - hast Du beim Anlegen evlt. einen Tippfehler drin gehabt?

Ich habe das Passwort aus der Konfigurationsdatei mal ausgebessert und entsprechend geändert, scheint wohl nun zu klappen! :blush:

1 Like

Ja die Datenbank ist vorhanden

Das Passwort hab ich hier extra nicht reingeschrieben.
Passwort für die Datenbank hab ich immer richtig eingetragen…

Das Passwort ist ja auch richtig, er kann nur irgendwie keine Verbindung herstellen

Dankeschön, jetzt funktioniert es.

Irgendwie komisch :smiley: Hab es unendliche mal überprüft, neu geschrieben ect.
ABer vielen vielen dank